6 thoughts on “Technical Documents

  1. I was sent a free smart plug by British Gas about a month after they installed a Hive to control my heating and hot water. Very pleased with the new controls for the hot water and heating (though confess I have not used the heating controls yet due to the warm September.)

    The problem is the plug. I can see it on my list of devices but whatever I do it always shows as offline. The device is busy flashing away in the hall a few feet from the main hive thermostat but nothing will make to appear as a live device. I have tried “install device” on the iPad and it refuses to to recognise the damned thing.

    What am I doing wrong?

    Thanks in advance for any help!

  2. Hi, thanks for this site. I hope you are continuing to enjoy your Hive.
    I am trying to rustle up some support to get Hive to enable the SmartPlug for remote control (rather than just being a signal booster plug).

    Would you be interested in voting for this product development on the Hive support site:


    I have also written an article on my blog reviewing the plugs:


    All the best,

  3. I ordered and paid up front for hive to be installed 7 weeks ago, waited for the day given to be installed 9/6/17 and to my surprise they had no record of me whatsoever on day of installation.
    After complaining and on the phone for 3 hours I got no satisfaction at all, only to be told I would have to wait yet another week.
    What the hell is going on Hive team/British Gas….even told that it would take three days to handle my complaint and come back to me.
    What a shambles for a so called reputable company, you wonder why you’re losing customers.
    So quick to take my £200 but try getting it back!
    If customers are getting hive free now, then why am I paying this money, when I’ve also joined for dual fuel?
    This deserves to go to the ombudsman!

  4. I have had Hive (originally British Gas) since 2012 and it has worked fine until recently. It has however now stopped being accessible remotely as the hub stops communicating with the Hive network. After a long discussion with Hive Support it seems if the broadband goes down or the power fails then the old style original hub that I have only tries to reconnect once. If that fails (which I gather it does most times) then it doesn’t try again and just sits there until you do a physical power off and re-boot. That is not very helpful when you are 150 miles away! Having used Hive for about 6 years, this has only started happening in the last 2 months or so. I gather that there must have been an update to the Hive network and it is that which is causing the hub not to connect. New hubs apparently get around this by having multiple re-tries but mine cannot be upgraded. Is anyone else experiencing this? Any idea how to solve it?

  5. I have had similar problems. I got my hub about 6 months ago and it appears to physically different to that available now. I would have thought this issue would be solved by a firmware update, but there does not seem a mechanism for a Hive user to do it. A brute force approach might be to put the hub on a timeswitch so that the power is interrupted for a few minutes (invoking a reboot) every 24 hours – say at 3 am.

  6. My hive camera hasn’t worked for months it works on WiFi but not on data. The message says Cannot connect to the server. Does anyone else get this problem

Leave a Reply

Your email address will not be published. Required fields are marked *